Author Topic: Couple of Issues  (Read 3928 times)

Steve125

  • Newbie
  • *
  • Posts: 4
    • View Profile
Couple of Issues
« on: January 09, 2009, 11:11:22 AM »
When I apply either back brake or front brake, the hazard lights flicker, not always and constantly, but almost as if there's a loose wiring or faulty earth.

It's the Lifan 125 Mohicano model. I'm confused about all these models, Lifan Arizona, which looks slightly different to the Lifan Mohicano. When I first got it I thought there had been modifications, but on looking at more pictures of the Mohicano, it seems they come with custom style grips, indicators as standard.

My second issue is that when I'm gaining speed, the needle will go up to 85mph before settling at the right speed in 5th gear, it seems to do this with high revs when the bike is moving.

chopper1

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Couple of Issues
« Reply #1 on: November 12, 2009, 01:48:24 PM »
hi i have had mine about 2 months had same problem with indicators flashing when brakes applied failed mot with same problem  checked all wiring no joy, so looked under seat for relay and for some reason seen colour wire same as brakeswitch wire so took chance and snipped wire on relay and now can brake without indicators flashing but everything still works, only diff is now the beeping noise to tell you indicators are on is not so loud not a bad thing because it was far to loud anyway . hope this helps, ps if you look at brake switch on footbrake live not earth then lift seat and on relay cut same colour wire as on brake.

lifanstreetfighter

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Couple of Issues
« Reply #2 on: January 28, 2012, 08:01:30 AM »
i have the same problem with mine i have a lifan lf12530 and the indicaters do the same thing lol. also my idicater noise was far too loud so i just found the box that made the noise and taped it up and now its at a far more reasonable sound :)

mpl1981

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Couple of Issues
« Reply #3 on: February 18, 2012, 09:07:28 AM »
Could someone let me know where the infernal beeping thing is....I want to destroy it (or at least quieten it )

Thanks in advance.

kleintoren

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Couple of Issues
« Reply #4 on: April 12, 2012, 11:26:21 AM »
I built up my 125 gy3 and learn a lot. had the same flashing problem but cut a wire the same color as wire going out to the tail light. mine flashes erratically (has from the beginning), what wattage should the indicator bulbs be?